Commit de093905 authored by Björn Peemöller 's avatar Björn Peemöller
Browse files

Version bump to 0.9.3

This version needs at least Cabal 1.8 and can now be compiled with GHC 7.4
parent 2e5d79c9
Name: KiCS
Version: 0.9.2
Cabal-Version: >= 1.6.0.3
Version: 0.9.3
Cabal-Version: >= 1.8
Author: Bernd Braßel
Maintainer: Bernd Braßel
Homepage: http://curry-language.org
Maintainer: Björn Peemöller
Homepage: http://www.curry-language.org
License: OtherLicense
License-File: LICENSE
Category: Compiler
......@@ -13,7 +13,8 @@ Description: This package builds the Curry to Haskell compiler "kics".
This package also includes many Curry libraries.
Have a look at the list of modules "Curry.Module.*"
Stability: experimental
extra-source-files:
extra-source-files:
src/lib/Curry/Module/*.hs.include
extra-tmp-files:
src/lib/Curry/Module/*.fcy
......@@ -30,22 +31,20 @@ Data-Files: Curry/Module/*.fcy
Curry/Module/*.uacy
Curry/Module/*.cy
debugOptions.hs
Executable kics
main-is: kics.hs
hs-source-dirs: src
Build-Depends:
base == 4.1.*,
haskell98,
mtl,
filepath,
old-time,
directory,
containers,
ghc-paths,
process,
curry-base >= 0.2.6,
curry-frontend >= 0.2.8
Build-Depends:
base == 4.*
, containers
, directory
, filepath
, ghc-paths
, old-time
, process
, curry-base >= 0.2.9 && < 0.3
, curry-frontend >= 0.2.12 && < 0.3
Other-Modules:
Curry.Compiler.Config
Curry.Compiler.CurryToHaskell
......@@ -63,20 +62,33 @@ Executable kicsi
main-is: kicsi.hs
hs-source-dirs: src
Build-Depends:
readline
base == 4.*
, containers
, directory
, filepath
, ghc-paths
, old-time
, process
, readline
, curry-base >= 0.2.9 && < 0.3
, curry-frontend >= 0.2.12 && < 0.3
Library
hs-source-dirs: src, src/lib
Build-Depends:
base == 4.1.*,
haskell98,
directory,
old-time,
syb,
network,
process,
unix,
random
Build-Tools: kics
Build-Depends:
base == 4.*
, containers
, directory
, filepath
, network
, old-time
, process
, random
, syb
, unix
, curry-frontend >= 0.2.12 && < 0.3
Exposed-Modules:
Curry.Files.KiCSPath
Curry.RunTimeSystem
......@@ -140,8 +152,3 @@ Library
Paths_KiCS
Curry.RunTimeSystem.Store
Curry.RunTimeSystem.BaseCurry
......@@ -35,7 +35,7 @@ unflag = fromFlagOrDefault silent
requireProg :: SS.Flag Verbosity -> LocalBuildInfo -> IO Program -> IO ()
requireProg verb lbi prog = do
p <- prog
requireProgram (unflag verb) p AnyVersion (withPrograms lbi)
requireProgram (unflag verb) p (withPrograms lbi)
return ()
callProg :: Verbosity -> LocalBuildInfo -> IO Program -> Args -> IO ()
......
Name: KiCS-debugger
Version: 0.1.1
Version: 0.1.2
Cabal-Version: >= 1.6
Author: Bernd Braßel
Maintainer: Bernd Braßel
......@@ -26,14 +26,13 @@ Data-Files:
Library
hs-source-dirs: .,biosphere/src
Build-Depends:
base == 4.1.*,
haskell98,
base == 4.*,
filepath,
syb,
containers,
mtl,
readline,
KiCS >= 0.9.1
KiCS >= 0.9.3
Exposed-Modules:
Curry.Files.KiCSDebugPath
......@@ -142,12 +141,11 @@ Executable mkstrict
main-is: mkstrict.hs
hs-source-dirs: prophecy, biosphere/src, .curry/kics
Build-Depends:
base == 4.1.*,
base == 4.*,
haskell-src,
directory,
curry-base >= 0.2.7,
KiCS >= 0.9.1,
KiCS-prophecy >= 0.1.1
KiCS >= 0.9.3,
KiCS-prophecy >= 0.1.2
Other-Modules:
Curry.Module.ObsoleteHigherOrder
Curry.Module.SrcRef
......
Name: KiCS-prophecy
Version: 0.1.1
Version: 0.1.2
Cabal-Version: >= 1.6
Author: Bernd Braßel
Maintainer: Bernd Braßel
......@@ -24,9 +24,9 @@ Data-Files:
Library
hs-source-dirs: .
Build-Depends:
base == 4.1.*,
base == 4.*,
filepath,
KiCS >= 0.9.1
KiCS >= 0.9.3
Exposed-Modules:
Curry.Files.ProphecyPath
......@@ -48,8 +48,8 @@ Executable prophecy
main-is: prophecy.hs
hs-source-dirs: ., .curry/kics
Build-Depends:
base == 4.1.*,
KiCS >= 0.9.1
base == 4.*,
KiCS >= 0.9.3
Other-Modules:
Curry.Module.AddWorld
Curry.Module.Wrapper
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment